Skip navigation.
Home
Semantic Software Lab
Concordia University
Montréal, Canada

Mulitpax not working with Supple Parser

Printer-friendly versionPrinter-friendly versionPDF versionPDF version

Hello,

I can not get the supple parser to work with mulitpax. Multipax does not catch anything from the suppler parser. I'm trying to use the supple parser because I can't get the stanford parser working properly (which I've posted else where)

Here are my setting for the supple parser:
INITIALIZATION:
SUPPLEFile: GATEHOME/plugins/Parser_SUPPLE/supple.swi
configFile: GATEHOME/plugins/Parser_SUPPLE/config/mapping.config
featurefile: GATEHOME/plugins/Parser_SUPPLE/config/feature_table.config
prologImplementation: shef.nlp.suppple.prolog.SWIProlog

debug: false
semanticsSetName:

SupplePAx Initialization Settings:
raspScript: file:/usr/local/durmtools/rasp-3.0/scripts/myRasp.sh

/*The rasp file does not exist, but I didn't think it matters because I'm looking at supple.*/

debugFlag: false
inputASName:
outputASName:
parserASName: supple

I'm looking for the rasp file, but I don't have anything like it.
Any help would be great.

Thanks!
Neal

rene's picture

SUPPLE working in GATE?

Did you check if SUPPLE itself is working? Try setting the runtime parameter semanticsSetName of the SUPPLE wrapper to "supple". You should then see the output of SUPPLE in the "supple" set (annotation type "semantics"). For MultiPaX, the parserASName runtime parameter must also be set to "supple" (case sensitive).

For the RASP wrapper script, check this thread: http://www.semanticsoftware.info/forum/multipax-and-rasp-wrapper-script

René

Supple works

Hello Rene,

Thank you for your quick response.

Supple is working fine for me. Before, the semantics was outside of "supple" tab. Now it is underneath it.

Unfortunately, the MuliPAX annotationSet is not coming up as it does with the Stanford parser.

Do you think it might have something to do with the rasp parser? I'm going to try to get the rasp.sh script and load it with MultiPAX.

Thanks again!

Neal

rene's picture

should work like with Stanford parser

Well, assuming you have set the parserASName runtime parameter in MultiPaX correctly ("supple", same case as the output from the parser), and you do not get any errors or warnings from MultiPaX, it should just work. How do your "semantics" annotations (in the "supple" set) look like? Note that if you want to extract the output from both Stanford and SUPPLE within the same pipeline, you need to add two MultiPaX PRs instances.

The extraction from RASP and SUPPLE are completely independent, you do not need to have RASP setup correctly to make SUPPLE work.

Hello again. I would like to

Hello again.

I would like to update you. I have rebuilt my supple Parser and also included the PLCafe prolog to work with it. I have no errors when I load GATE or create the processes (supple or multipax). Both supple parsers running either SWI or PLCafe, with semanticsSetName as "supple" (both were run separately),
The supple parsers seem to work fine in them selves, in that I'm getting their annotationSets (parse and supple) and can produce syntax trees if I want.

I have upgraded to the latest version of MultiPaX (1.2) and have rebuilt it. I am still getting the same problem. There are no errors when I load GATE, no errors while running the pipleine, and at the end, I have "extracting supple PAS!" message from the MultiPaX. But I am not getting any AnnotationSet from MultiPaX

I have a feeling that I am making some very simple silly mistake. However, I have triple checked the case of "supple" in multiPAX, and semanticsSetName(all lowercase),

I am going to try to reinstall GATE and make sure that all of my configurations are good. But if MuliPaX works with Stanford parser, why not supple?

Thanks for all of your help! If you have any more suggestions, please let me know. I'll update you if/when I find out what I'm doing wrong.

Neal

I've also tried setting the

I've also tried setting the MultiPAX outputASName to "supplePAX" This creates a grayed out annotationSet "supplePAX". There is nothing beneath it.

Hello! So, I've disabled

Hello!

So, I've disabled the stanford parser and PAX from my pipeline. This is all that is in my pipeline:

1. Document Reset PR
2. ANNIE English Tokeniser
3. ANNIE POS Tagger
4. Morphological Analyzer
5. Supple Parser (settings same as previous)
6. MultiPAX (settings the same as previous message)

After running the pipeline on a corpus I have several annotation sets:

Under the blank arrow:
Sentence
SpaceToken
Split
SyntaxTreeNode
Token
parse

Orginial Markups:
paragraph

supple:
semantics

Messages related to MultiPAX and supple:
CREOLE plugin loaded: file:/home/neal/GATE-5.2.1/plugins/MultiPaX-1.1/

However, I am getting errors for my supple parsers, but also getting messages that it loaded.

Error opening JAR file:/home/neal/GATE-5.2.1/plugins/Parser_SUPPLE/prolog-impls/plcafe-impl.jar specified in creole file file:/home/neal/GATE-5.2.1/plugins/Parser_SUPPLE/creole.xml: java.io.FileNotFoundException: /home/neal/GATE-5.2.1/plugins/Parser_SUPPLE/prolog-impls/plcafe-impl.jar (No such file or directory)
Error opening JAR file:/home/neal/GATE-5.2.1/plugins/Parser_SUPPLE/prolog-impls/sicstus-impl.jar specified in creole file file:/home/neal/GATE-5.2.1/plugins/Parser_SUPPLE/creole.xml: java.io.FileNotFoundException: /home/neal/GATE-5.2.1/plugins/Parser_SUPPLE/prolog-impls/sicstus-impl.jar (No such file or directory)

CREOLE plugin loaded: file:/home/neal/GATE-5.2.1/plugins/Parser_SUPPLE/

And even notices that it's working:
"extracting supple PAS!"

I don't know how to interpret the semantics output,
but here are a few of the outputss. For the phrase "She notes that a brother" :
semantics supple 76 100 22084 {qlf=[pronoun(e3, 'She'), realisation(e3, offsets(76, 79)), '_'(e2), time(e2, present), aspect(e2, simple), voice(e2, active), that(e2, e4), '_'(e4), number(e4, sing), det(e4, a), realisation(e4, offsets(91, 100)), realisation(e2, offsets(80, 100)), realisation(e2, offsets(80, 100)), lsubj(e2, e3)]}

and "is no smoke exposure"
semantics supple 207 227 22090 {qlf=['_'(e18), time(e18, present), aspect(e18, simple), voice(e18, active), lobj(e18, e19), '_'(e19), number(e19, sing), '_'(e20), qual(e19, e20), number(e20, sing), realisation(e20, offsets(213, 218)), det(e19, no), realisation(e19, offsets(210, 227)), realisation(e18, offsets(207, 227)), realisation(e18, offsets(207, 227))]}

reload my supple parser and find those files?

One thing: I'm not using plcafe, but swiprolog for the supple parser. perhaps I should use plcafe?

rene's picture

Looks all good

This looks all good (except you missed the SentenceSplitter in your pipeline list, but I assume you have one, otherwise your pipeline would throw an error).

The Prolog you are using for running SUPPLE should not make a difference in the results (only in the performance).

Could you send us one of the documents you are trying to process so that we can try it here. Perhaps there is something else going on.

Link to the text

Hello again Rene!

Thanks again for all of your help. here is the text (google doc link). This is the same text that the Stanford parser PAX misses most of the objects on.
If you guys run it and get the same problems, then it must be the nature of the text I'm running.

Thank you!

Neal

rene's picture

Works ok...

Hello Neal,

I've tried the text, exported from Google Docs as plain "Text" and loaded into GATE, and MultiPaX does find PASs with SUPPLE (114 in total):

  1. extracting supple PAS!
  2.  
  3. ...
  4.  
  5. ---New PAS---
  6.  
  7. lverb : e49: had
  8. lsubj : e50: Her brother
  9. lobj : e52: prostate cancer

So it must be something in your configuration, but from what you described I don't see anything wrong. I guess we'll have to wait until Ralf comes back and can have a look...

However, SUPPLE+MultiPaX do not find many objects in this text either. I suspect this is due to the writing style, which is significantly different from the newspaper style the parsers have been trained on. MiniPar and RASP seems to find more objects, but I didn't check if they are actually correct.

Rene, thanks! I'm glad to

Rene,

thanks! I'm glad to know that it's just possible. The writing style is going to be a problem with these documents, but I guess that's why it's interesting.

I'm running on linux and am using the supple parser provided by gate. I might have built MultiPaX incorrectly. I just ran "ant jar" from the multipax directory. Of course, I could have something wrong from the supple build as well.

Thanks for all of your help Rene. I appreciate it.

Neal

rene's picture

We're also developing on

We're also developing on Linux; if PAX compiles with "ant jar" and works for the other parsers, I don't see what should be wrong with it.

Likewise, the "semantics" annotations created by the SUPPLE plug-in look ok to me as well.

You might want to try MiniPar and see if this works as expected.

Hi!!!! Any solution for this thread!?

Hi!!

I am working on a Mac OS 10.7 and I am using the supple parser with MultiPaX.
I am having the same problem that you were working on plus that under my supple tab of annotations I don´t have the semantics annotations.
As I am working with Mac Os I can´t use Miniparser or Standford.

The Sentence annotations look pretty good in the tree view, but it doesn´t show features in the annotation list.

Thanks!!!!

Azu

rene's picture

SUPPLE configuration

Hi,

If you don't have "semantics" annotations in the "supple" annotation set (or whatever your "semanticsSetName" is set to in the SUPPLE PR), then your SUPPLE parser is not set up correctly, so you need to solve this before you can use MultiPax.

In case you haven't done so yet, check the GATE documentation and the gate-users mailing list on how to configure SUPPLE.

Good luck,

René